can't launch wallet on ubuntu 16.04



  • hello,

    I downloaded the Debian 64 qt file, made it executable.
    When I run it from a terminal it returns me :
    "./Bitradiod: error while loading shared libraries: libboost_system.so.1.55.0: cannot open shared object file: No such file or directory"

    I downloaded Qt for Pi3 raspbian, unzipped it.
    When I get into the folder (uncompressed) of Bitradio-Qt-Daemon-rpi3-V1000 and run "qmake -qt=qt5 USE_UPNP=- && make"
    I have a page where qmake is explained :
    "Usage: /usr/lib/x86_64-linux-gnu/qt5/bin/qmake [mode] [options] [files]

    QMake has two modes, one mode for generating project files based on
    some heuristics, and the other for generating makefiles. Normally you
    shouldn't need to specify a mode, as makefile generation is the default
    mode for qmake, but you may use this to test qmake on an existing project

    Mode:
    -project Put qmake into project file generation mode
    In this mode qmake interprets files as files to
    be built,
    ..."

    Could you help me please?

    Thanks



  • If you downloaded the compiled, use a script to export the path of "boost " and "db-4.8.30"

    code example only with boost libs

    #!/bin/sh
    export LD_LIBRARY_PATH="<full path>/boost/lib:$LD_LIBRARY_PATH"
    ./Bitradio-qt
    

    chmod +x yourscript.sh

    and execute ./youscript.sh

    When running the script it will fetch the exported libs just for this execution, and thus will not affect other scripts

    Now if you're trying to compile the source, follow my steps at: http://forum.bitrad.io/topic/420/debian-installation-problem/2

    Remembering that where it is:

    cd ../Bitradio-master/
    

    Refers to the directory created by the "git clone" command, if you rename it or the directory is saved with another name, then use the new name.



  • hello and thanks for your answer.

    I'm quite new under linux.
    When i read what you wrote me, it seemed to me it would be more simple to follow the steps you give in http://forum.bitrad.io/topic/420/debian-installation-problem

    everything was ok until the command :
    ./bjam install
    some errors appeared telling he cannot access to some files.
    I ran it a second time, this was far quickly... but it didn't work much...

    here are the last lines :
    ...failed common.copy /usr/local/lib/libboost_unit_test_framework.a...
    common.copy /usr/local/lib/libboost_test_exec_monitor.a
    cp: impossible de créer le fichier standard '/usr/local/lib/libboost_test_exec_monitor.a': Permission non accordée

    cp "bin.v2/libs/test/build/gcc-5.4.0/release/link-static/threading-multi/libboost_test_exec_monitor.a"  "/usr/local/lib/libboost_test_exec_monitor.a"
    

    ...failed common.copy /usr/local/lib/libboost_test_exec_monitor.a...
    ...failed updating 69 targets...
    ...skipped 13547 targets...

    I tried sudo ./bjam install which didn't work...

    That's probably obvious ... but i can't understand.

    Thx



  • @apo
    the command

    ./bjam install
    

    Install on the system then you need root to run it.
    try:

    sudo ./bjam install

Log in to reply
 

Looks like your connection to Bitrad.io was lost, please wait while we try to reconnect.