Debian installation problem

  • Hello world,
    I want to install the wallet for debian but I don't know how can I launch installation I have 2 files: "Bitradiod" and "Bitradio-qt" and when I try to launch one of these, installation is not launching.
    If someone has solution thanks for his help.
    Thanks for future help.
    PS: Sorry for my english if it's bad/

  • AlphaShadows77 said in Debian installation problem:


    Compile from source: https://github.com/thebitradio/Bitradio
    DOC: https://github.com/thebitradio…/master/doc/build-unix.md

    Code
    1. mkdir -p bitradio-wallet && cd bitradio-wallet/git clone https://github.com/thebitradio/Bitradio.gitwget http://download.oracle.com/berkeley-db/db-4.8.30.NC.tar.gztar -xzvf db-4.8.30.NC.tar.gzwget https://dl.bintray.com/boostorg/release/1.64.0/source/boost_1_64_0.tar.gztar -xzvf boost_1_64_0.tar.gzsudo apt-get install build-essential libtool automake autotools-dev autoconf pkg-config libssl-dev libgmp3-dev libevent-dev bsdmainutilssudo apt-get install libminiupnpc-devsudo apt-get install libqt5gui5 libqt5core5a libqt5dbus5 qttools5-dev qttools5-dev-tools libprotobuf-dev protobuf-compilersudo apt-get install libqrencode-devcd boost_1_64_0/./bootstrap.sh./bjam installcd ../Bitradio-master/BITRADIO_ROOT=$(pwd)BDB_PREFIX="${BITRADIO_ROOT}/db4"mkdir -p $BDB_PREFIXcd ../db-4.8.30.NC/build_unix/../dist/configure --enable-cxx --disable-shared --with-pic --prefix=$BDB_PREFIXmake installcd $BITRADIO_ROOTmake clean && make distclean


    open Bitradio.pro with your editor favorite, and add lines after "TEMPLATE = app":

    Code
    1. BDB_INCLUDE_PATH = db4/includeBDB_LIB_PATH = db4/lib


    example result:

    Code
    1. TEMPLATE = appBDB_INCLUDE_PATH = db4/includeBDB_LIB_PATH = db4/libTARGET = Bitradio-qt


    Save and close, return to console:

    Code
    1. qmake -qt=qt5 USE_UPNP=- && make


    Done success? Execute ./Bitradio-qt and wait sync

  • Hi!
    I'm also having problems installing Bitradiod on Debian distribution. I'm going through steps described here: https://github.com/thebitradio…/master/doc/build-unix.md but having an error when configuring Berkeley DB 4.8:

    Code
    1. BITRADIO_ROOT=$(pwd)# Pick some path to install BDB to, here we create a directory within the BITRADIO directoryBDB_PREFIX="${BITRADIO_ROOT}/db4"mkdir -p $BDB_PREFIX# Fetch the source and verify that it is not tampered withwget 'http://download.oracle.com/berkeley-db/db-4.8.30.NC.tar.gz'echo '12edc0df75bf9abd7f82f821795bcee50f42cb2e5f76a6a281b85732798364ef db-4.8.30.NC.tar.gz' | sha256sum -c# -> db-4.8.30.NC.tar.gz: OKtar -xzvf db-4.8.30.NC.tar.gz# Build the library and install to our prefixcd db-4.8.30.NC/build_unix/# Note: Do a static build so that it can be embedded into the executable, instead of having to find a .so at runtime../dist/configure --enable-cxx --disable-shared --with-pic --prefix=$BDB_PREFIXmake install# Configure BITRADIO Core to use our own-built instance of BDBcd $BITRADIO_ROOT./autogen.sh./configure LDFLAGS="-L${BDB_PREFIX}/lib/" CPPFLAGS="-I${BDB_PREFIX}/include/" # (other args...)


    The errors I have:

    Code
    1. wiewiorka@MasterNode1:~/Bitradio$ ./autogen.sh
    2. -bash: ./autogen.sh: No such file or directory
    3. wiewiorka@MasterNode1:~/Bitradio$ ./configure LDFLAGS="-L${BDB_PREFIX}/lib/" CPPFLAGS="-I${BDB_PREFIX}/include/"
    4. -bash: ./configure: No such file or directory


    Bitradio is the directory where I cloned the git repository (https://github.com/thebitradio/Bitradio), and the value of $BITRADIO_ROOT is /home/wiewiorka/Bitradio.. but there's no autogen.sh file in this directory.. I see the file of the same name in Bitradio/src/secp256k1 but it's not what the manual says.. Am I missing something?

  • Ok, I've managed to find a workaround for Berkeley DB configuration. I've checked the contents of the file Bitradio/src/makefile.unix :

    Code
    1. ...
    2. DEFS=-DBOOST_SPIRIT_THREADSAFE
    3. DEFS += $(addprefix -I,$(CURDIR) $(CURDIR)/obj $(BOOST_INCLUDE_PATH) $(BDB_INCLUDE_PATH) $(OPENSSL_INCLUDE_PATH))
    4. LIBS = $(addprefix -L,$(BOOST_LIB_PATH) $(BDB_LIB_PATH) $(OPENSSL_LIB_PATH))
    5. ...


    and set the variables $(BDB_INCLUDE_PATH) and $(BDB_LIB_PATH) to reference the corresponding locations of the installed Berkley DB: Bitradio/db4/include and Bitradio/db4/lib
    and then compiled bitradiod: make -f makefile.unix USE_UPNP=-
    The other problem I had: I've received a bunch of compilation errors when trying to compile on Debian 9.1. It doesn't seem to work on that version, I had to revert to Debian 7.11.

  • tinoman@linuxNet:~/Descargas/bitradio$ ./Bitradiod

    ./Bitradiod: error while loading shared libraries: libboost_system.so.1.55.0: cannot open shared object file: No such file or directory



    help error wallet instalation in debian linux